Looking at the statistic, IPv4 will be exhausted in this year. I think it is time to get ready for IPv6. Unfortunately, look like none of the ISP in Australia are providing IPv6 addresses to their customers.
At least, as far as I know TPG, Exetel, Optus and Telstra, etc are not providing IPv6 as yet. However, Google has already laughed their IPv6 web site. Can you try connecting to http://ipv6.google.com ? if you see something, congarduation! Your computer can access IPv6 website and your ISP has a DNS resolver that can point your to a ipv6 website.
Oh…. not sure what I am talking about??? Point your web browser to http://www.test-ipv6.com or http://www.ipv6-test.com both site will test your ipv6 and ipv4 connectivity. It should give you some idea of what I am talking about.
In order to test out the IPv6 connectivity, I have built a IPv6 tunnel to http://www.he.net . HE has assigned me a /64 and /48 IPv6 public address. I have that setup on my router, every computer in my home is now IPv6 ready. There are more than enough ip addresses in a /48, so I routed some of them to my web server in the data center.
here are the sample configuration.
Configuration on my cisco router:
[code]
interface Tunnel2
description IPV6 tunnel to webserver
no ip address
ipv6 address 2001:470:ECEE:2::2/64
tunnel source YY.YY.YY.YY
tunnel destination XX.XX.XX.XX
tunnel mode ipv6ip
[/code]
Configuration on my web server (debian linux)
[code]
ip tunnel add ipv6tunnel mode sit remote YY.YY.YY.YY
ip link set ipv6tunnel up
ip addr add 2001:470:ECEE:2::1/64 dev ipv6tunnel
ip route add 0::0/0 dev ipv6tunnel
echo 1 > /proc/sys/net/ipv6/conf/all/forwarding
[/code]
in my cisco router, there is another tunnel for me to connect to www.he.net for the ipv6 connecitivity.
[code]
interface Tunnel0
description Hurricane Electric IPv6 Tunnel Broker
no ip address
ipv6 address 2001:470:35:4D::2/64
ipv6 enable
tunnel source YY.YY.YY.YY
tunnel destination 216.218.221.42
tunnel mode ipv6ip
[/code]
a default route for ipv6 need to be added on the router as well
[code]
ipv6 route ::/0 Tunnel0
[/code]
After all the setting, it will be time to do some test. First, try
[code]
ping6 ipv6.google.com
[/code]
in the debain server, which I got a host not found message. It was because I don’t have a IPv6 DNS setup. To get this fix, I did the following:
[code]
vi /etc/resolv.conf
[/code]
adding the HE.net DNS resolver address
[code]
nameserver=2001:470:20::2
[/code]
After setting the DNS server, do the ping6 again, it should work now. After setting IPv6 for the web server, I also want all my computes at home obtain an IPv6 ip address automantically and also receivce the ipv6 DNS automantically. here are the CLI command to configurate a IPv6 DHCP pool:
[code]
ipv6 dhcp pool datalan
address prefix 2001:470:ECEE::/64
dns-server 2001:470:20::2
[/code]
After rebooting a PC, it automantically recevice the IPv6 address and able to pass all the test on http://www.test-ipv6.com.
My next project will be setting up a PPTP ipv6 VPN, so I can access IPv6 website while I am on a IPv4 endpoint via the PPTP tunnel. I will post the configuration up if I am able to make this work.
7 responses to “IPV6 – Are you ready?”